指标公式网-网站首页
|
|
|
|
股票指标公式:通达信指标公式 大智慧指标公式 同花顺指标公式 飞狐指标公式 书刊: 股票图书 技术书籍 入门书刊
股市实战技巧:炒股技巧 短线技巧 跟庄技巧   止损技巧 高手心得   投资误区 心理分析 每日一招 交易指南 股票风险

股票技术分析:K线分析 MACD技巧 KDJ技术 DMI技巧 ADR技术 RSI技巧 股票成交量 选股方法 图形分析 买卖攻略
股票入门知识:股票入门 股票术语 基础知识 基本面分析 基础分析 宏观分析 财务分析 新股申购 政策法规 宏观分析
|
|
|
|
大盘分析室|名站导航
全球股市 | 沪深在线
港股 |黄金 |原油 |美元
首页
99操盘
每日热点事件
股票指标公式
股市实战技巧
股票技术分析
股票入门知识
超赢数据查询
股市名人
股票图书馆
站内找资料 热门标签: 指标 公式 股票 主图 源码 高手 波段 选股 趋势 主力 短线 分享 免费 副图 抄底 资金 买进 牛股 黑马 买卖
 本站由投资者99创建,如果您还为每天是否涨跌而劳累,那么建议别再东奔西走了,指标公式网就是您要找的地方,学会判断股票趋势是炒股的真谛,
 如果没有股票基础,其它分析也不会,怎么办?那么指标公式网建议您掌握本站超赢数据里的BS买卖点就可以了,本站致力于提高您的炒股分析水平。
指标公式网
指标公式网
    股票指标公式分类 ->  [通达信指标公式]    [大智慧指标公式]    [同花顺指标公式]    飞狐指标公式    
    当前位置: 主页 > 股票指标公式 > 飞狐指标公式 > - 飞狐股票波段操作源码五星黄金柱主图指标公式 发布时间:2015-03-11 02:11:52 --【自荐浏览:指标公式网站长8年实盘记录】

飞狐股票波段操作源码五星黄金柱主图指标公式

 

INPUT:M1(5,1,999),M2(35,1,999),M3(135,1,999);
黄金柱:=V/REF(V,1)>=2.0;
K1:=SUMBARS(黄金柱,1) ;
K2:=SUMBARS(黄金柱,2);
K3:=SUMBARS(黄金柱,3);
K4:=SUMBARS(黄金柱,4);
K5:=SUMBARS(黄金柱,5);
K6:=SUMBARS(黄金柱,6);
K7:=SUMBARS(黄金柱,7);
K8:=SUMBARS(黄金柱,8);
K9:=SUMBARS(黄金柱,9);
K10:=SUMBARS(黄金柱,10);
STICKLINE(K1,REF(L,K1-1)*1.002,REF(L,K1-1),10,0),COLORYELLOW;
AA:K1,COLORYELLOW,LINETHICK;
{预定黄金柱}
{预定黄金柱:=REF(V,2)>=REF(V,3)*1.99 AND REF(C,2)>REF(O,2)
AND REF(V,2)=HHV(V,3) AND C/REF(C,2) >=1.0995 AND REF(L,2)=LLV(L,3);}
{预定:STICKLINE(预定黄金柱,H,H,30,0),COLORRED;}
{DRAWICON(预定黄金柱,H,19);}
{将军柱中的五星上将黄金柱}
T60:=V=HHV(V,60);
T100:=V=HHV(V,100);
T2:=V/REF(VOL,1)>=3;
T3:=REF(C,1)/REF( O,1)<3;
五星上将:=(T60 AND T2 AND T3) OR (T100 AND T2 AND T3);
DRAWICON(五星上将,H,23);
{量柱图}
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,8,0),COLORWHITE;
STICKLINE(涨停,H,L,0,0),COLORWHITE;
DRAWICON(涨停,L-0.2,11);
DRAWTEXT(涨停,L-0.2,' --涨停');
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,8,0),COLORBLUE;
STICKLINE(跌停,H,L,0,1),COLORBLUE;
DRAWICON(跌停,H+0.2,2);
DRAWTEXT(跌停,H+0.2,' --跌停');
{大阳线:=IF((C-C2)*100/C2>=5,1,0) AND IF((C-C2)*100/C2<(10-0.01*100/C2),1,0) OR IF((C-O)*100/O>=5,1,0) AND IF((C-C2)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阳线,OPEN,CLOSE,-1,0),COLORRED;
STICKLINE(大阳线,H,L,0,1),COLORRED;
大阴线:=IF((C2-C)*100/C2>=5,1,0) AND IF((C2-C)*100/C2<(10-0.01*100/C2),1,0) OR IF((O-C)*100/O>=5,1,0) AND IF((C2-C)*100/C2<(10-0.01*100/C2),1,0);
STICKLINE(大阴线,OPEN,CLOSE,-1,0),COLORGREEN;
STICKLINE(大阴线,H,L,0,1),COLORGREEN;}
{MA13:MA(CLOSE,13),COLORWHITE;
MA34:MA(CLOSE,34),COLORYELLOW;
MA55:MA(CLOSE,55),COLOR9933FF;}
{MA4:MA(CLOSE,4),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLOR9933FF;
MA30:MA(CLOSE,30),COLORLIBLUE;
MA60:MA(CLOSE,60),COLORWHITE;
MA120:MA(CLOSE,120),COLORLIGREEN;}
TY:=C;
AA1:=REF(TY,10)=HHV(TY,2*10+1); BB1:=FILTER(AA1,10); C1:=BACKSET(BB1,10+1); HD:=FILTER(C1,10);
AA2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(AA2,10); CC2:=BACKSET(B2,10+1); LD:=FILTER(CC2,10);
前期高位:REF(H,BARSLAST(HD)),COLOR00FF00,POINTDOT,LINETHICK3;
前期低位:REF(L,BARSLAST(LD)),COLORFF00FF,POINTDOT,LINETHICK3;
{求位置坐标}
PHD:=IF(LLV(L,3)>=REF(H,3),REF(H,3),
IF((LLV(L,3)>=REF(C,3) AND REF(C,3)>REF(O,3)),REF(C,3),
IF(LLV(L,3)>=REF(O,3) AND REF(C,3)>REF(O,3),REF(O,3),REF(L,3))));
{自动画量能平台}
{NN 1 300 21}
{NN:=21;
TTJ:=BARSLAST(REF(倍量黄金柱,NN-1));
K0:=TTJ=0;
K1:=SUMBARS(K0,1);
K2:=SUMBARS(K0,2);
K3:=SUMBARS(K0,3);
K4:=SUMBARS(K0,4);
K5:=SUMBARS(K0,5);
K6:=SUMBARS(K0,6);
K7:=SUMBARS(K0,7);
K8:=SUMBARS(K0,8);
K9:=SUMBARS(K0,9);
K10:=SUMBARS(K0,10);
CCCC1:=REF(C,K1-1);}
{在K线图上标示量柱类型}
DRAWICON((VOL>REF(V,1)*2.0 OR VOL=REF(V,1)*2.0) AND C>REF(C,1),H+0.2,26);
倍量:=(VOL>REF(V,1)*2.0 OR VOL=REF(V,1)*2.0) AND C>REF(C,1);
DRAWICON(VOL<REF(LLV(VOL,13),1),H+0.1,2);
低量:=VOL<REF(LLV(VOL,13),1);
DRAWICON(VOL<REF(LLV(VOL,100),1),H+0.1,12);
地量:=VOL<REF(LLV(VOL,100),1);
DRAWICON(ABS(VOL-HHV(REF(VOL,1),5))/HHV(REF(VOL,1),5)<=0.03 OR ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.03,H+0.1,16);
平量:=ABS(VOL-HHV(REF(VOL,1),5))/HHV(REF(VOL,1),5)<=0.03 OR ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.03;
DRAWICON(VOL<=REF(V,1)*0.5,H+0.1,27);
倍缩:=VOL<=REF(V,1)*0.5;
{画量柱标识:}
{1.画倍量黄金柱标识--红箭头图标}
DRAWICON((LLV(L,3)>REF(L,3) OR LLV(L,3)=REF(L,3)) AND HHV(V,3)<REF(V,3) AND
REF(C,3)>REF(O,3) AND REF(V,3)>=2*REF(V,4),H+0.2,1);
倍量黄金柱:=(LLV(L,3)>REF(L,3) OR LLV(L,3)=REF(L,3)) AND HHV(V,3)<REF(V,3) AND
REF(C,3)>REF(O,3) AND REF(V,3)>=2*REF(V,4);
{2.画梯量黄金柱标识--橘子图标}
DRAWICON(LLV(L,3)>REF(L,3) AND HHV(V,3)<REF(V,3) AND
REF(V,5)>REF(V,6) AND REF(V,4)>REF(V,5) AND REF(V,3)>REF(V,4),H,17);
梯量黄金柱:=LLV(L,3)>REF(L,3) AND HHV(V,3)<REF(V,3) AND
REF(V,5)>REF(V,6) AND REF(V,4)>REF(V,5) AND REF(V,3)>REF(V,4);
{3.画平量黄金柱标识--苹果图标}
DRAWICON(LLV(L,3)>REF(L,3) AND HHV(V,3)<REF(V,3) AND
REF(C,3)>REF(O,3) AND ABS(REF(V,3)-REF(V,4))/REF(V,4)<=0.03,H,19);
平量黄金柱:=LLV(L,3)>REF(L,3) AND HHV(V,3)<REF(V,3) AND
REF(C,3)>REF(O,3) AND ABS(REF(V,3)-REF(V,4))/REF(V,4)<=0.03;
{4.画立桩量标识--顶部红箭头图标}
N:=25;
立桩量:=REF(V,3)/REF(MA(V,5),4)>(N/10) AND
REF(V,3)/REF(HHV(V,60),4)>1.5 AND LLV(L,3)>REF(L,3);
STICKLINE(倍量,OPEN,CLOSE,8,0),COLORYELLOW;
STICKLINE(倍量黄金柱,PHD,PHD,60,0),COLORWHITE;
倍量黄金线:倍量黄金柱,COLORWHITE,LINETHICK;
DRAWICON(倍量黄金柱,PHD*1.008,12);
DRAWTEXT(倍量黄金柱,PHD*1.010,' 标准黄金柱精准线'),COLORFF00FF;
DRAWTEXT(倍量黄金柱,PHD,'================='),COLORWHITE;
{平量黄金线:STICKLINE(平量黄金柱,PHD*1.002,PHD,100,0),COLORYELLOW;
DRAWTEXT(平量黄金柱,PHD*1.015,'平量黄金线'),COLORLIGREEN ;
梯量黄金线:STICKLINE(梯量黄金柱,PHD*1.002,PHD,100,0),COLORYELLOW;
DRAWTEXT(梯量黄金柱,PHD*1.015,'梯量黄金线'),COLORFF00FF ;}
DRAWICON(立桩量,H*1.002,1);
立桩量标识:立桩量,LINETHICK;
DRAWTEXT(立桩量,H*1.06,'立'),COLORRED;
DRAWTEXT(立桩量,H*1.04,'桩'),COLORRED;
DRAWTEXT(立桩量,H*1.02,'量'),COLORRED;
{DA:STICKLINE(K4<=30,REF(C,K4-1)*1.002,REF(C,K4-1),10,0),COLORBLUE;
EA:STICKLINE(K5<=30,REF(C,K5-1)*1.002,REF(C,K5-1),10,0),COLORBLUE;
FA:STICKLINE(K6<=30,REF(C,K6-1)*1.002,REF(C,K6-1),10,0),COLORBLUE;
GA:STICKLINE(K7<=30,REF(C,K7-1)*1.002,REF(C,K7-1),10,0),COLORBLUE;
HA:STICKLINE(K8<=30,REF(C,K8-1)*1.002,REF(C,K8-1),10,0),COLORBLUE;
IA:STICKLINE(K9<=30,REF(C,K9-1)*1.002,REF(C,K9-1),10,0),COLORBLUE;
JA:STICKLINE(K10<=30,REF(C,K10-1)*1.002,REF(C,K10-1),10,0),COLORBLUE; }
AAA:=REFX(HHV(H,90),DATACOUNT-BARPOS);
TS1:=0+0.03;
TS2:=TS1+0.03;
TS3:=TS2+0.03;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS1),'<一>.量柱的阶段性拐点标志--空间转化原则:'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS2),' 1.平台起柱:在K线整理平台上突然起柱;'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS3),' 2.凹口起柱:在K线逐步回调形成凹口时起柱.常见凹口倍量;'),COLORFF00FF ;
TS4:=TS3+0.03;
TS5:=TS4+0.03;
TS6:=TS5+0.03;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS4),' 3.过顶起柱:过左峰起柱.常见过顶倍量;'),COLORFF00FF;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS5),' 4.触底起柱:触前期谷底起柱.常见触底倍量.'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS6),'<二>.量柱的集合定性--组合量柱:'),COLORFF00FF ;
TS7:=TS6+0.03;
TS8:=TS7+0.03;
TS9:=TS8+0.03;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS7),' 1.低量柱+倍量柱:后市必大涨!'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS8),' 2.倍量柱+倍量柱:主庄控盘良好,急于拉升!'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=158,AAA-(AAA*TS9),' 3.缩倍柱+倍量柱:机会就在眼前!'),COLORFF00FF ;
{============================}
BBB:=REFX(HHV(H,190),DATACOUNT-BARPOS);
TT1:=0+0.03;
TT2:=TT1+0.03;
TT3:=TT2+0.03;
DRAWTEXT(DATACOUNT-BARPOS+1=300,BBB-(BBB*TT1),'<三>.量柱的三日定性--时间转化原则:'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=300,BBB-(BBB*TT2),' 1.后三日价升量缩:转化为黄金柱;'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=300,BBB-(BBB*TT3),' 2.后三日量柱先阴后阳:该量柱官升一级;'),COLORFF00FF ;
TT4:=TT3+0.03;
TT5:=TT4+0.03;
DRAWTEXT(DATACOUNT-BARPOS+1=300,BBB-(BBB*TT4),' 3.后三日量柱阴阳相间:量柱退化,走势面临调整;'),COLORFF00FF ;
DRAWTEXT(DATACOUNT-BARPOS+1=300,BBB-(BBB*TT5),' 4.后三日量柱实体逐步缩小:力量将衰退,面临调整.'),COLORFF00FF ;
{底部趋势拐点}
VVOL:=IF(ISLASTBAR AND DATATYPE=6,VOL*240/OPENMINUTES(CURRENTTIME),VOL);
VOLUME:=VOL;
AAG:=VOL>=REF(V,1)*1.91 AND C>REF(C,1);
AA1G:=VOL<REF(LLV(VOL,21),1);
AA2G:=VOL<REF(LLV(VOL,55),1);
AA3G:=ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.05;
MAVOL5:=MA(VOLUME,M1);
MAVOL35:=MA(VOLUME,M2);
MAVOL135:=MA(VOLUME,M3);
VOLUME5:=MA(VOLUME,M1);
VOLUME35:=MA(VOLUME,M2);
VOLUME135:=MA(VOLUME,M3);
买入:=CROSS(VOLUME5,VOLUME135);
DRAWICON(买入,L,9);
买入1:=CROSS(VOLUME35,VOLUME135);
DRAWICON(买入1,L,5);
买入2:=CROSS(VOLUME5,VOLUME35);
DRAWICON(买入2,L,1);
{非常棒}
EMA13:=EMA(C,13),COLORWHITE;
EMA21:=EMA(C,21),COLORYELLOW;
EMA34:=EMA(C,34),COLORFF00FF;
EMA60:=MA(C,60),COLORFFCC66;
VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLORLIRED;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),COLORGREEN;
DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1);
DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2);
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWICON(卖出<0,H+0.05,2);
买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
B1:IF(CROSS(买线,卖线),L-0.02,0),LINETHICK,COLORMAGENTA;
PARTLINE(CROSS(买线,卖线),L-0.02),CROSSDOT,LINETHICK3,COLORMAGENTA;
S1:IF(CROSS(80,"RSI")*30,H+0.02,0),LINETHICK,COLORYELLOW;
PARTLINE(CROSS(80,"RSI")*30,H+0.02),CROSSDOT,LINETHICK3,COLORYELLOW;
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,0),LINETHICK,COLORGREEN;
PARTLINE(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02),CIRCLEDOT,LINETHICK3,COLORGREEN;
A0:=(L+H+C*2)/4;
A1B:EMA(A0,14),COLORBLUE,LINETHICK2;
A2B:=EMA(A0,25),COLORC0C000,LINETHICK2;
A1X:=(A1B-REF(A1B,1))/REF(A1B,1)*100;
A2X:=(A2B-REF(A2B,1))/REF(A2B,1)*100;
看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),0),COLORMAGENTA,LINETHICK;
PARTLINE(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))),COLORMAGENTA,LINETHICK1;
逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),0),COLORCYAN,LINETHICK;
PARTLINE(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X)))),COLORCYAN,LINETHICK1;
买入持股:IF(A1X>=0,A1B,0),COLORRED,LINETHICK;
PARTLINE(A1X>=0,A1B),COLORRED,LINETHICK3;
卖出空仓:IF(A1X<0 AND A2X<0,A1B,0),COLORGREEN,LINETHICK;
PARTLINE(A1X<0 AND A2X<0,A1B),COLORGREEN,LINETHICK3;
{STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC;
STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF;
STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;};

飞狐五星黄金柱主图指标公式

 



【一.其它相关股票指标公式】

上一篇:飞狐股票洗盘结束抄底介入源码免费指标公式
下一篇:飞狐股票KDJ集结号抄底买入就涨的源码免费指标公式

【二.飞狐股票波段操作源码五星黄金柱主图指标公式】是非常实用的股票技术指标公式,建议大家收藏这个股票公式!技术指标安装可以参考:(通达信指标安装方法)(大智慧指标安装方法)(同花顺指标安装方法)(飞狐指标安装方法)




指标公式网-免费股票指标公式源码 业务联系
网站地图 浙ICP备14038126号-4